summaryrefslogtreecommitdiffstats
path: root/Tests/UseWX/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-07-21 19:43:19 (GMT)
committerBrad King <brad.king@kitware.com>2006-07-21 19:43:19 (GMT)
commit3c9744f406d85a293fc504368d32ba34b5ed3332 (patch)
treeae48986833aa8d1aabb369c88e832e769d9ef5af /Tests/UseWX/CMakeLists.txt
parentb377c8ac725aea5a7b892b830b29fb80355cb097 (diff)
downloadCMake-3c9744f406d85a293fc504368d32ba34b5ed3332.zip
CMake-3c9744f406d85a293fc504368d32ba34b5ed3332.tar.gz
CMake-3c9744f406d85a293fc504368d32ba34b5ed3332.tar.bz2
ENH: Applying patch from bug#3443 to implement FindwxWidgets.cmake properly. It also updates the UseWX test and WXDialog sources to use the new find script.
Diffstat (limited to 'Tests/UseWX/CMakeLists.txt')
-rw-r--r--Tests/UseWX/CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/Tests/UseWX/CMakeLists.txt b/Tests/UseWX/CMakeLists.txt
index 139339a..ac997ff 100644
--- a/Tests/UseWX/CMakeLists.txt
+++ b/Tests/UseWX/CMakeLists.txt
@@ -1,9 +1,7 @@
-PROJECT (UsewxWindows)
+PROJECT (UsewxWidgets)
-INCLUDE( ${CMAKE_ROOT}/Modules/Use_wxWindows.cmake)
+FIND_PACKAGE(wxWidgets REQUIRED)
+INCLUDE( ${wxWidgets_USE_FILE} )
ADD_EXECUTABLE (UseWX WIN32 WX.cxx)
-
-#TODO:
-#- dll linking is not working on WIN32, need to '-DWXUSINGDLL' to preprocessor
-
+TARGET_LINK_LIBRARIES(UseWX ${wxWidgets_LIBRARIES} )