summaryrefslogtreecommitdiffstats
path: root/Tests/VSMARMASM/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2023-01-26 17:55:41 (GMT)
committerBrad King <brad.king@kitware.com>2023-01-26 17:56:25 (GMT)
commitb44714a6429c48c2cabe53fce100bc20c6f8fbfc (patch)
treeea4ac4cf359f41312e2d212a4efa86a9516fdbf0 /Tests/VSMARMASM/CMakeLists.txt
parented09c0aecd7c68b3ad2af805fda1449f799a6eae (diff)
downloadCMake-b44714a6429c48c2cabe53fce100bc20c6f8fbfc.zip
CMake-b44714a6429c48c2cabe53fce100bc20c6f8fbfc.tar.gz
CMake-b44714a6429c48c2cabe53fce100bc20c6f8fbfc.tar.bz2
VS: Honor compile options for ASM_MARMASM
The Ninja and Makefile generators honor `target_compile_options` and friends for ASM_MARMMASM `.asm` sources. Teach the VS generator to honor them too for consistency. Issue: #24289
Diffstat (limited to 'Tests/VSMARMASM/CMakeLists.txt')
-rw-r--r--Tests/VSMARMASM/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/VSMARMASM/CMakeLists.txt b/Tests/VSMARMASM/CMakeLists.txt
index 6d78e04..85740de 100644
--- a/Tests/VSMARMASM/CMakeLists.txt
+++ b/Tests/VSMARMASM/CMakeLists.txt
@@ -1,3 +1,6 @@
cmake_minimum_required(VERSION 3.25) # Enable CMP0141
project(VSMARMASM C ASM_MARMASM)
add_executable(VSMARMASM main.c foo.asm)
+target_compile_options(VSMARMASM PRIVATE
+ "$<$<COMPILE_LANGUAGE:ASM_MARMASM>:SHELL:-predefine \"zero SETA 0\">"
+ )