summaryrefslogtreecommitdiffstats
path: root/Tests/VSManagedCustomCommand/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-12-03 13:54:23 (GMT)
committerKitware Robot <kwrobot@kitware.com>2021-12-03 13:54:33 (GMT)
commit67cbfed81981a25aa56a3d05a267c1acf6ea5781 (patch)
tree19a020f41949e8055f0ae8ec2d94df8226ffa382 /Tests/VSManagedCustomCommand/CMakeLists.txt
parentd565f9f0ee849e541036d26dc1bd69e6ce908d84 (diff)
parent13a7ae2194d44f955712d65fecf0b741049da00e (diff)
downloadCMake-67cbfed81981a25aa56a3d05a267c1acf6ea5781.zip
CMake-67cbfed81981a25aa56a3d05a267c1acf6ea5781.tar.gz
CMake-67cbfed81981a25aa56a3d05a267c1acf6ea5781.tar.bz2
Merge topic 'vs-csproj-scripts' into release-3.22
13a7ae2194 VS: Revert "Add missing label in C# project-build events" Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !6781
Diffstat (limited to 'Tests/VSManagedCustomCommand/CMakeLists.txt')
-rw-r--r--Tests/VSManagedCustomCommand/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/Tests/VSManagedCustomCommand/CMakeLists.txt b/Tests/VSManagedCustomCommand/CMakeLists.txt
new file mode 100644
index 0000000..2228875
--- /dev/null
+++ b/Tests/VSManagedCustomCommand/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 3.20)
+project(VSManagedCustomCommand CXX)
+
+add_custom_command(OUTPUT middle.txt
+ COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_SOURCE_DIR}/example.txt ${CMAKE_CURRENT_BINARY_DIR}/middle.txt
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/example.txt
+ )
+
+add_custom_command(OUTPUT example.cxx
+ COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_BINARY_DIR}/middle.txt ${CMAKE_CURRENT_BINARY_DIR}/example.cxx
+ DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/middle.txt
+ )
+
+add_library(example SHARED example.cxx)
+set_property(TARGET example PROPERTY COMMON_LANGUAGE_RUNTIME "")