summaryrefslogtreecommitdiffstats
path: root/Tests/VSResource/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-06-26 13:38:35 (GMT)
committerBrad King <brad.king@kitware.com>2015-06-26 14:07:08 (GMT)
commit806609c7024dbf07a639a9d77074d4bc82ae1b8a (patch)
tree9722ec7e2129e407ff10794fb5c5035c0a6a9e2f /Tests/VSResource/CMakeLists.txt
parentdcc2a7ccd4f8d9612b224d7106a4c3cfcd48e6fc (diff)
downloadCMake-806609c7024dbf07a639a9d77074d4bc82ae1b8a.zip
CMake-806609c7024dbf07a639a9d77074d4bc82ae1b8a.tar.gz
CMake-806609c7024dbf07a639a9d77074d4bc82ae1b8a.tar.bz2
VS: Add /machine: flag to Librarian tool (#11240)
If a Windows resource (.rc) source file is included in a STATIC library, the VS "link" tool will process the compiled ".res" file and needs to know the target architecture. Without it, we may get a LNK4068 warning and possibly a LNK1112 error. Add /machine: to the default static library flags to give the link tool the information it needs.
Diffstat (limited to 'Tests/VSResource/CMakeLists.txt')
-rw-r--r--Tests/VSResource/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/VSResource/CMakeLists.txt b/Tests/VSResource/CMakeLists.txt
index 17eb041..3b9cfc3 100644
--- a/Tests/VSResource/CMakeLists.txt
+++ b/Tests/VSResource/CMakeLists.txt
@@ -46,7 +46,10 @@ else()
include_directories(${CMAKE_CURRENT_BINARY_DIR})
endif()
+add_library(ResourceLib STATIC lib.cpp lib.rc)
+
add_executable(VSResource main.cpp test.rc)
+target_link_libraries(VSResource ResourceLib)
set_property(TARGET VSResource
PROPERTY VS_GLOBAL_CMakeTestVsGlobalVariable "test val")