summaryrefslogtreecommitdiffstats
path: root/Tests/VSWinStorePhone/CMakeLists.txt
diff options
context:
space:
mode:
authorGilles Khouzam <gillesk@microsoft.com>2019-02-01 17:40:58 (GMT)
committerBrad King <brad.king@kitware.com>2019-02-01 18:04:52 (GMT)
commitcff026dbc01f975857236a11fc033af48b5e130a (patch)
treeb9d95dad15a93df1bc6f41084731451893c88a6e /Tests/VSWinStorePhone/CMakeLists.txt
parent6c21722adbc1745b6362ca9501692805c19eb8ac (diff)
downloadCMake-cff026dbc01f975857236a11fc033af48b5e130a.zip
CMake-cff026dbc01f975857236a11fc033af48b5e130a.tar.gz
CMake-cff026dbc01f975857236a11fc033af48b5e130a.tar.bz2
VS: Fix WinRT component references
WinRT components need to be referenced in a similar way that managed code libraries are referenced. Validate that the library reference is a WinRT component and reference it through the project. Add test coverage for `VS_WINRT_COMPONENT`. While at it, fix the IOT reference failing on Win10 SDK 17763 which doesn't include it anymore. Fixes: #18846
Diffstat (limited to 'Tests/VSWinStorePhone/CMakeLists.txt')
-rw-r--r--Tests/VSWinStorePhone/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/Tests/VSWinStorePhone/CMakeLists.txt b/Tests/VSWinStorePhone/CMakeLists.txt
index eefd9a6..efc7760 100644
--- a/Tests/VSWinStorePhone/CMakeLists.txt
+++ b/Tests/VSWinStorePhone/CMakeLists.txt
@@ -8,6 +8,8 @@ elseif(MSVC_VERSION GREATER 1600)
set(COMPILER_VERSION "11")
endif()
+add_subdirectory(WinRT)
+
set (APP_MANIFEST_NAME Package.appxmanifest)
if("${CMAKE_SYSTEM_NAME}" STREQUAL "WindowsPhone")
set(PLATFORM WP)
@@ -149,5 +151,4 @@ if("${SHORT_VERSION}" STREQUAL "10.0")
set_property(TARGET ${EXE_NAME} PROPERTY VS_SDK_REFERENCES "Microsoft.UniversalCRT.Debug, Version=${CMAKE_VS_WINDOWS_TARGET_PLATFORM_VERSION}")
endif()
-
-target_link_libraries(${EXE_NAME} d3d11)
+target_link_libraries(${EXE_NAME} d3d11 JusticeLeagueWinRT)