summaryrefslogtreecommitdiffstats
path: root/Tests/VSWinStorePhone/CMakeLists.txt
diff options
context:
space:
mode:
authorGilles Khouzam <gillesk@microsoft.com>2016-06-17 21:24:21 (GMT)
committerBrad King <brad.king@kitware.com>2016-06-20 14:46:14 (GMT)
commited05f11dd27d668791887f32e2c7be00753cfdb5 (patch)
treea1d88212b3c218f7afbf3773252b68fdeed67f02 /Tests/VSWinStorePhone/CMakeLists.txt
parent313e9667021a510151117d8222e958174b691261 (diff)
downloadCMake-ed05f11dd27d668791887f32e2c7be00753cfdb5.zip
CMake-ed05f11dd27d668791887f32e2c7be00753cfdb5.tar.gz
CMake-ed05f11dd27d668791887f32e2c7be00753cfdb5.tar.bz2
VS: Add a VS_TOOL_OVERRIDE source file property
This property allow to specify a specific Visual Studio tool for a source file overriding the default tool behavior. For example, a `.resw` file being processed as a `PriResource` file. This has the advantage of being able to teach CMake to process new file types without code modifications.
Diffstat (limited to 'Tests/VSWinStorePhone/CMakeLists.txt')
-rw-r--r--Tests/VSWinStorePhone/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/Tests/VSWinStorePhone/CMakeLists.txt b/Tests/VSWinStorePhone/CMakeLists.txt
index ae82755..6b026fc 100644
--- a/Tests/VSWinStorePhone/CMakeLists.txt
+++ b/Tests/VSWinStorePhone/CMakeLists.txt
@@ -98,13 +98,17 @@ elseif (NOT "${PLATFORM}" STREQUAL "DESKTOP")
)
endif()
+set(STRING_FILES
+ Direct3DApp1/Strings/en-US/Resources.resw)
+
set(RESOURCE_FILES
- ${CONTENT_FILES} ${DEBUG_CONTENT_FILES} ${RELEASE_CONTENT_FILES} ${ASSET_FILES}
+ ${CONTENT_FILES} ${DEBUG_CONTENT_FILES} ${RELEASE_CONTENT_FILES} ${ASSET_FILES} ${STRING_FILES}
Direct3DApp1/Direct3DApp1_TemporaryKey.pfx)
set_property(SOURCE ${CONTENT_FILES} PROPERTY VS_DEPLOYMENT_CONTENT 1)
set_property(SOURCE ${ASSET_FILES} PROPERTY VS_DEPLOYMENT_CONTENT 1)
set_property(SOURCE ${ASSET_FILES} PROPERTY VS_DEPLOYMENT_LOCATION "Assets")
+set_property(SOURCE ${STRING_FILES} PROPERTY VS_TOOL_OVERRIDE "PRIResource")
set_property(SOURCE ${DEBUG_CONTENT_FILES} PROPERTY VS_DEPLOYMENT_CONTENT $<CONFIG:Debug>)
set_property(SOURCE ${RELEASE_CONTENT_FILES} PROPERTY
VS_DEPLOYMENT_CONTENT $<OR:$<CONFIG:Release>,$<CONFIG:RelWithDebInfo>,$<CONFIG:MinSizeRel>>)