summaryrefslogtreecommitdiffstats
path: root/Tests/iOSNavApp/CMakeLists.txt
diff options
context:
space:
mode:
authorGregor Jasny <gjasny@googlemail.com>2015-08-20 20:29:49 (GMT)
committerGregor Jasny <gjasny@googlemail.com>2015-08-25 19:53:51 (GMT)
commitd2c2319d6479d4319ef298f6178b00e953a9b179 (patch)
tree801b6d63d38e29b12898af28986911163ab84822 /Tests/iOSNavApp/CMakeLists.txt
parentcdb9984bff78b8f76c3b8c3f622928e4f29920a1 (diff)
downloadCMake-d2c2319d6479d4319ef298f6178b00e953a9b179.zip
CMake-d2c2319d6479d4319ef298f6178b00e953a9b179.tar.gz
CMake-d2c2319d6479d4319ef298f6178b00e953a9b179.tar.bz2
Replace CMAKE_XCODE_EFFECTIVE_PLATFORMS with call to PlatformIsAppleIos
Currently the CMAKE_XCODE_EFFECTIVE_PLATFORMS property acts only as a kind of toggle switch to enable iOS project layout features. But instead of relying on this undocumented property, better detect the presence of an iOS SDK directly.
Diffstat (limited to 'Tests/iOSNavApp/CMakeLists.txt')
-rw-r--r--Tests/iOSNavApp/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/Tests/iOSNavApp/CMakeLists.txt b/Tests/iOSNavApp/CMakeLists.txt
index 12c3ada..1fc33e0 100644
--- a/Tests/iOSNavApp/CMakeLists.txt
+++ b/Tests/iOSNavApp/CMakeLists.txt
@@ -3,7 +3,6 @@ project(NavApp3)
set(CMAKE_OSX_SYSROOT iphoneos4.3)
set(CMAKE_OSX_ARCHITECTURES "armv6;armv7;i386")
-set(CMAKE_XCODE_EFFECTIVE_PLATFORMS "-iphoneos;-iphonesimulator")
include_directories(
${CMAKE_CURRENT_SOURCE_DIR}