summaryrefslogtreecommitdiffstats
path: root/Utilities/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-02-03 01:18:39 (GMT)
committerBrad King <brad.king@kitware.com>2006-02-03 01:18:39 (GMT)
commit02f743c896c154ecdb20d8c02b872e28ef4f48ac (patch)
tree5a1753658294a1b12874dba1d962833ed356d03b /Utilities/CMakeLists.txt
parentca4b82d9ed74e8ef6b65df384e7ae79a993eb4f9 (diff)
downloadCMake-02f743c896c154ecdb20d8c02b872e28ef4f48ac.zip
CMake-02f743c896c154ecdb20d8c02b872e28ef4f48ac.tar.gz
CMake-02f743c896c154ecdb20d8c02b872e28ef4f48ac.tar.bz2
COMP: Fixed build on VC++ Express 2005. Explicitly testing for MFC to determine whether to build the MFCDialog.
Diffstat (limited to 'Utilities/CMakeLists.txt')
-rw-r--r--Utilities/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Utilities/CMakeLists.txt b/Utilities/CMakeLists.txt
index 5e88fff..70b3e28 100644
--- a/Utilities/CMakeLists.txt
+++ b/Utilities/CMakeLists.txt
@@ -74,7 +74,7 @@ IF(UNIX)
ENDIF(CURSES_LIBRARY)
ENDIF(UNIX)
-IF(CMAKE_BUILD_ON_VISUAL_STUDIO)
+IF(BUILD_MFCDialog)
SET(CMD ${CMD_DIR}/CMakeSetup${CMD_EXT})
ADD_CUSTOM_COMMAND(
OUTPUT ${CMake_BINARY_DIR}/Docs/CMakeSetup.txt
@@ -93,7 +93,7 @@ IF(CMAKE_BUILD_ON_VISUAL_STUDIO)
${CMake_BINARY_DIR}/Docs/CMakeSetup.html
)
SET(DOC_FILES ${DOC_FILES} ${CMake_BINARY_DIR}/Docs/CMakeSetup.txt)
-ENDIF(CMAKE_BUILD_ON_VISUAL_STUDIO)
+ENDIF(BUILD_MFCDialog)
# Drive documentation generation.
ADD_CUSTOM_TARGET(documentation ALL