summaryrefslogtreecommitdiffstats
path: root/Utilities/Doxygen/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Barre <sebastien.barre@kitware.com>2001-11-02 21:05:37 (GMT)
committerSebastien Barre <sebastien.barre@kitware.com>2001-11-02 21:05:37 (GMT)
commitbc673070bc5f5fccdf404fd687ee57c9bb6f0684 (patch)
treef4b2aa5097c6793f858f2f1cb9d5884e2a5b0d78 /Utilities/Doxygen/CMakeLists.txt
parent3f4eeeaa8a41c4fd49b96225e1b79a0ca899ef8e (diff)
downloadCMake-bc673070bc5f5fccdf404fd687ee57c9bb6f0684.zip
CMake-bc673070bc5f5fccdf404fd687ee57c9bb6f0684.tar.gz
CMake-bc673070bc5f5fccdf404fd687ee57c9bb6f0684.tar.bz2
Doxygen doc generator
Diffstat (limited to 'Utilities/Doxygen/CMakeLists.txt')
-rw-r--r--Utilities/Doxygen/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/Utilities/Doxygen/CMakeLists.txt b/Utilities/Doxygen/CMakeLists.txt
new file mode 100644
index 0000000..f17215b
--- /dev/null
+++ b/Utilities/Doxygen/CMakeLists.txt
@@ -0,0 +1,23 @@
+#
+# Build the documentation
+#
+INCLUDE (${CMAKE_ROOT}/Modules/DocumentationVTK.cmake OPTIONAL)
+
+IF (BUILD_DOCUMENTATION)
+
+ #
+ # Configure the script and the doxyfile, then add target
+ #
+ CONFIGURE_FILE(
+ ${CMAKE_SOURCE_DIR}/Utilities/Doxygen/doxyfile.in
+ ${CMAKE_BINARY_DIR}/Utilities/Doxygen/doxyfile)
+
+ CONFIGURE_FILE(
+ ${CMAKE_SOURCE_DIR}/Utilities/Doxygen/doc_makeall.sh.in
+ ${CMAKE_BINARY_DIR}/Utilities/Doxygen/doc_makeall.sh)
+
+ ADD_CUSTOM_TARGET(DoxygenDoc
+ ${BASH}
+ ${CMAKE_BINARY_DIR}/Utilities/Doxygen/doc_makeall.sh)
+
+ENDIF (BUILD_DOCUMENTATION)