summaryrefslogtreecommitdiffstats
path: root/Utilities/Release/WiX/CMakeLists.txt
diff options
context:
space:
mode:
authorNils Gladitz <nilsgladitz@gmail.com>2016-02-07 19:25:56 (GMT)
committerBrad King <brad.king@kitware.com>2016-02-09 15:28:57 (GMT)
commita12b0f1b193024b71583b9150aeead33d364d189 (patch)
treef94b0230c6bfdb8e72b1572877fcadcb0d6d2a72 /Utilities/Release/WiX/CMakeLists.txt
parenta5a5a6857241c21d306661d723b749839f4c6e1a (diff)
downloadCMake-a12b0f1b193024b71583b9150aeead33d364d189.zip
CMake-a12b0f1b193024b71583b9150aeead33d364d189.tar.gz
CMake-a12b0f1b193024b71583b9150aeead33d364d189.tar.bz2
CMake: Prevent WiX installations over existing NSIS installations
Use a custom action to look for Uninstall.exe in the user selected installation prefix. Its presence indicates a previous NSIS installation. Inform the user and request manual resolution of the issue.
Diffstat (limited to 'Utilities/Release/WiX/CMakeLists.txt')
-rw-r--r--Utilities/Release/WiX/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Utilities/Release/WiX/CMakeLists.txt b/Utilities/Release/WiX/CMakeLists.txt
new file mode 100644
index 0000000..cc0dbe1
--- /dev/null
+++ b/Utilities/Release/WiX/CMakeLists.txt
@@ -0,0 +1,12 @@
+add_subdirectory(CustomAction)
+
+if(CMAKE_CONFIGURATION_TYPES)
+ set(CUSTOM_ACTION_OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/custom_action_dll-$<CONFIG>.wxs")
+else()
+ set(CUSTOM_ACTION_OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/custom_action_dll.wxs")
+endif()
+
+file(GENERATE
+ OUTPUT "${CUSTOM_ACTION_OUTPUT}"
+ INPUT "${CMAKE_CURRENT_SOURCE_DIR}/custom_action_dll.wxs.in"
+ )