summaryrefslogtreecommitdiffstats
path: root/Utilities/Sphinx/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2014-04-10 08:36:43 (GMT)
committerStephen Kelly <steveire@gmail.com>2014-04-10 15:30:57 (GMT)
commit111bb67c14e90e372be300cbbd98fa88d87a8b99 (patch)
tree4656ba50eef2ee3cf358d4fedcb436c86ddd239a /Utilities/Sphinx/CMakeLists.txt
parent5c63c1319030222b1dbf49684ee303c5532f2a3b (diff)
downloadCMake-111bb67c14e90e372be300cbbd98fa88d87a8b99.zip
CMake-111bb67c14e90e372be300cbbd98fa88d87a8b99.tar.gz
CMake-111bb67c14e90e372be300cbbd98fa88d87a8b99.tar.bz2
Help: Use a more-appropriate qthelp namespace and file name.
Use the namespace org.cmake instead of org.sphinx.cmake. Add the version to the output file name.
Diffstat (limited to 'Utilities/Sphinx/CMakeLists.txt')
-rw-r--r--Utilities/Sphinx/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Utilities/Sphinx/CMakeLists.txt b/Utilities/Sphinx/CMakeLists.txt
index 4ae4bec..0ae67bd 100644
--- a/Utilities/Sphinx/CMakeLists.txt
+++ b/Utilities/Sphinx/CMakeLists.txt
@@ -79,6 +79,11 @@ if(SPHINX_QTHELP)
# https://codereview.qt-project.org/#change,82250 in Qt 4.
COMMAND ${CMAKE_COMMAND} "-DCSS_DIR=${CMAKE_CURRENT_BINARY_DIR}/qthelp/_static"
-P "${CMAKE_CURRENT_SOURCE_DIR}/apply_qthelp_css_workaround.cmake"
+ # Workaround sphinx configurability:
+ # https://bitbucket.org/birkenfeld/sphinx/issue/1448/make-qthelp-more-configurable
+ COMMAND ${CMAKE_COMMAND} "-DQTHELP_DIR=${CMAKE_CURRENT_BINARY_DIR}/qthelp/"
+ "-DCMake_VERSION=${CMake_VERSION_MAJOR}${CMake_VERSION_MINOR}${CMake_VERSION_PATCH}"
+ -P "${CMAKE_CURRENT_SOURCE_DIR}/fixup_qthelp_names.cmake"
COMMAND qcollectiongenerator ${CMAKE_CURRENT_BINARY_DIR}/qthelp/CMake.qhcp
)
endif()