summaryrefslogtreecommitdiffstats
path: root/Utilities/cmexpat/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-04-19 15:06:04 (GMT)
committerBrad King <brad.king@kitware.com>2021-04-20 15:44:25 (GMT)
commit408e6d6185427dc57470f5685e9774e579bd6283 (patch)
tree5963e511c7658897b5f72aec588abe4df495f169 /Utilities/cmexpat/CMakeLists.txt
parent995be1097c35fd3187d147494156bbfb9da7037f (diff)
downloadCMake-408e6d6185427dc57470f5685e9774e579bd6283.zip
CMake-408e6d6185427dc57470f5685e9774e579bd6283.tar.gz
CMake-408e6d6185427dc57470f5685e9774e579bd6283.tar.bz2
Utilities: Suppress warnings in third-party code with NVHPC
Diffstat (limited to 'Utilities/cmexpat/CMakeLists.txt')
-rw-r--r--Utilities/cmexpat/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Utilities/cmexpat/CMakeLists.txt b/Utilities/cmexpat/CMakeLists.txt
index b8dc4e8..9048096 100644
--- a/Utilities/cmexpat/CMakeLists.txt
+++ b/Utilities/cmexpat/CMakeLists.txt
@@ -1,6 +1,6 @@
# Disable warnings to avoid changing 3rd party code.
IF(CMAKE_C_COMPILER_ID MATCHES
- "^(GNU|Clang|AppleClang|XLClang|XL|VisualAge|SunPro|HP|Intel|IntelLLVM)$")
+ "^(GNU|Clang|AppleClang|XLClang|XL|VisualAge|SunPro|HP|Intel|IntelLLVM|NVHPC)$")
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -w")
ELSEIF(CMAKE_C_COMPILER_ID STREQUAL "PathScale")
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -woffall")