summaryrefslogtreecommitdiffstats
path: root/Utilities/cmlibarchive/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-12-20 17:01:04 (GMT)
committerBrad King <brad.king@kitware.com>2011-12-22 15:38:34 (GMT)
commit1d7ea8b6294fac24ceaac742da8b7d3ff734a06f (patch)
treeba4bdd37d69de138c6fee519bd17dc0812c50215 /Utilities/cmlibarchive/CMakeLists.txt
parentd31bb538ef900a1f0a29d35fe4b2b2d91adc90fd (diff)
downloadCMake-1d7ea8b6294fac24ceaac742da8b7d3ff734a06f.zip
CMake-1d7ea8b6294fac24ceaac742da8b7d3ff734a06f.tar.gz
CMake-1d7ea8b6294fac24ceaac742da8b7d3ff734a06f.tar.bz2
libarchive: Do not build subdirectories not in reduced snapshot
Remove add_subdirectory() calls for directories not included in the reduced libarchive snapshot. Remove options that configure settings in the missing directories.
Diffstat (limited to 'Utilities/cmlibarchive/CMakeLists.txt')
-rw-r--r--Utilities/cmlibarchive/CMakeLists.txt15
1 files changed, 0 insertions, 15 deletions
diff --git a/Utilities/cmlibarchive/CMakeLists.txt b/Utilities/cmlibarchive/CMakeLists.txt
index aed3c0a..49c9b66 100644
--- a/Utilities/cmlibarchive/CMakeLists.txt
+++ b/Utilities/cmlibarchive/CMakeLists.txt
@@ -63,18 +63,9 @@ INCLUDE(AddTest28)
OPTION(ENABLE_NETTLE "Enable use of Nettle" ON)
OPTION(ENABLE_OPENSSL "Enable use of OpenSSL" ON)
-OPTION(ENABLE_TAR "Enable tar building" ON)
-OPTION(ENABLE_TAR_SHARED "Enable dynamic build of tar" FALSE)
-OPTION(ENABLE_CPIO "Enable cpio building" ON)
-OPTION(ENABLE_CPIO_SHARED "Enable dynamic build of cpio" FALSE)
OPTION(ENABLE_XATTR "Enable extended attribute support" ON)
OPTION(ENABLE_ACL "Enable ACL support" ON)
OPTION(ENABLE_ICONV "Enable iconv support" ON)
-OPTION(ENABLE_TEST "Enable unit and regression tests" ON)
-
-IF(ENABLE_TEST)
- ENABLE_TESTING()
-ENDIF(ENABLE_TEST)
IF(WIN32)
SET(_WIN32_WINNT 0x0500 CACHE INTERNAL "Setting _WIN32_WINNT to 0x0500 for Windows 2000 APIs")
@@ -1097,10 +1088,4 @@ IF(APPLE)
LIST(APPEND ADDITIONAL_LIBS "-framework CoreServices")
ENDIF(APPLE)
-IF(ENABLE_TEST)
- ADD_CUSTOM_TARGET(run_all_tests)
-ENDIF(ENABLE_TEST)
-
add_subdirectory(libarchive)
-add_subdirectory(tar)
-add_subdirectory(cpio)