summaryrefslogtreecommitdiffstats
path: root/Utilities/cmlibarchive/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-12-14 22:26:47 (GMT)
committerBrad King <brad.king@kitware.com>2009-12-14 22:26:47 (GMT)
commit68374fe078916be7536f8bc107b75a8a9db578e5 (patch)
treeae606e34fedea3218a2442c7f339a9727fee1261 /Utilities/cmlibarchive/CMakeLists.txt
parente4ebb49717cf8dca50807d7aee6cb0eba5b4d936 (diff)
downloadCMake-68374fe078916be7536f8bc107b75a8a9db578e5.zip
CMake-68374fe078916be7536f8bc107b75a8a9db578e5.tar.gz
CMake-68374fe078916be7536f8bc107b75a8a9db578e5.tar.bz2
libarchive: Drop unused %jd and %lld checks
The libarchive source does not use HAVE_PRINTF_JD or HAVE_PRINTF_LLD, so we do not need to test for them at configuration time.
Diffstat (limited to 'Utilities/cmlibarchive/CMakeLists.txt')
-rw-r--r--Utilities/cmlibarchive/CMakeLists.txt26
1 files changed, 0 insertions, 26 deletions
diff --git a/Utilities/cmlibarchive/CMakeLists.txt b/Utilities/cmlibarchive/CMakeLists.txt
index 9720a7d..e95935a 100644
--- a/Utilities/cmlibarchive/CMakeLists.txt
+++ b/Utilities/cmlibarchive/CMakeLists.txt
@@ -678,32 +678,6 @@ IF(ENABLE_ACL)
CHECK_SYMBOL_EXISTS(ACL_USER "${INCLUDES}" HAVE_ACL_USER)
ENDIF(ENABLE_ACL)
-# Check whether printf() supports "%jd"
-CHECK_C_SOURCE_RUNS("
- #include <stdint.h>
- #include <stdio.h>
- #include <string.h>
- static char buf[100];
- int main() {
- sprintf(buf, \"%jd\", (intmax_t)7);
- if (strcmp(buf, \"7\")) return 1;
- sprintf(buf, \"%ju\", (uintmax_t)7);
- return (strcmp(buf, \"7\"));
- }" HAVE_PRINTF_JD)
-
-# Check whether printf() supports "%lld"
-CHECK_C_SOURCE_RUNS("
- #include <stdint.h>
- #include <stdio.h>
- #include <string.h>
- static char buf[100];
- int main() {
- sprintf(buf, \"%lld\", (long long)7);
- if (strcmp(buf, \"7\")) return 1;
- sprintf(buf, \"%llu\", (long long)7);
- return (strcmp(buf, \"7\"));
- }" HAVE_PRINTF_LLD)
-
# Generate "config.h" from "build/cmake/config.h.in"
CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/build/cmake/config.h.in
${CMAKE_CURRENT_BINARY_DIR}/config.h)