summaryrefslogtreecommitdiffstats
path: root/Utilities/cmlibarchive/cpio/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2012-01-09 19:10:01 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2012-01-09 19:10:01 (GMT)
commit5a5c32e1f22cae3cdba3e5be142ee84b9e4a8d4d (patch)
tree7ac1ebd509d98ed93d796ce3bf0be1778a20dfe5 /Utilities/cmlibarchive/cpio/CMakeLists.txt
parente1c07a4342b719b982ffa099d930d2e193591114 (diff)
parent6c611c6b94ef54cbfdc81a1f049032f13a0ef024 (diff)
downloadCMake-5a5c32e1f22cae3cdba3e5be142ee84b9e4a8d4d.zip
CMake-5a5c32e1f22cae3cdba3e5be142ee84b9e4a8d4d.tar.gz
CMake-5a5c32e1f22cae3cdba3e5be142ee84b9e4a8d4d.tar.bz2
Merge topic 'update-libarchive'
6c611c6 libarchive: Restore CMake 2.6.3 as minimum version 2f5b677 libarchive: Update README-CMake.txt for new snapshot 156cb3b Merge branch 'libarchive-upstream' into update-libarchive fd42bf1 libarchive: Set .gitattributes to allow trailing whitespace 4f4fe6e libarchive 3.0.2-r4051 (reduced) 65b6e19 libarchive: Avoid bogus conversion warning from PGI compiler 9ccaeb1 libarchive: Suppress PathScale compiler warnings 2309438 libarchive: Rename isoent_rr_move_dir parameter isoent => curent b6ca96e libarchive: Include linux/types.h before linux/fiemap.h f293b73 libarchive: Define _XOPEN_SOURCE=500 on HP-UX 6781a09 libarchive: Cleanup after ZLIB_WINAPI check f15d757 libarchive: Remove hard-coded build configuration 3a9f449 libarchive: Use Apple copyfile.h API only if available 6af6b96 libarchive: Do not use MNT_NOATIME if not defined 02d5e40 libarchive: Check for 'struct statvfs' member 'f_iosize' 8b7ee30 libarchive: Do not use ST_NOATIME if not defined ...
Diffstat (limited to 'Utilities/cmlibarchive/cpio/CMakeLists.txt')
-rw-r--r--Utilities/cmlibarchive/cpio/CMakeLists.txt54
1 files changed, 0 insertions, 54 deletions
diff --git a/Utilities/cmlibarchive/cpio/CMakeLists.txt b/Utilities/cmlibarchive/cpio/CMakeLists.txt
deleted file mode 100644
index 84934ad..0000000
--- a/Utilities/cmlibarchive/cpio/CMakeLists.txt
+++ /dev/null
@@ -1,54 +0,0 @@
-############################################
-#
-# How to build bsdcpio
-#
-############################################
-IF(ENABLE_CPIO)
-
- SET(bsdcpio_SOURCES
- cmdline.c
- cpio.c
- cpio.h
- cpio_platform.h
- ../libarchive_fe/err.c
- ../libarchive_fe/err.h
- ../libarchive_fe/lafe_platform.h
- ../libarchive_fe/line_reader.c
- ../libarchive_fe/line_reader.h
- ../libarchive_fe/matching.c
- ../libarchive_fe/matching.h
- ../libarchive_fe/pathmatch.c
- ../libarchive_fe/pathmatch.h
- )
- INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/../libarchive_fe)
- IF(WIN32 AND NOT CYGWIN)
- LIST(APPEND bsdcpio_SOURCES cpio_windows.c)
- LIST(APPEND bsdcpio_SOURCES cpio_windows.h)
- ENDIF(WIN32 AND NOT CYGWIN)
-
- # bsdcpio documentation
- SET(bsdcpio_MANS bsdcpio.1)
-
- # How to build bsdcpio
- ADD_EXECUTABLE(bsdcpio ${bsdcpio_SOURCES})
- IF(ENABLE_CPIO_SHARED)
- TARGET_LINK_LIBRARIES(bsdcpio archive ${ADDITIONAL_LIBS})
- ELSE(ENABLE_CPIO_SHARED)
- TARGET_LINK_LIBRARIES(bsdcpio archive_static ${ADDITIONAL_LIBS})
- ENDIF(ENABLE_CPIO_SHARED)
- # On Windows, DLL must end up in same dir with EXEs
- IF(WIN32 AND NOT CYGWIN)
- SET_TARGET_PROPERTIES(bsdcpio PROPERTIES
- RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
- ENDIF(WIN32 AND NOT CYGWIN)
- # Full path to the compiled executable (used by test suite)
- GET_TARGET_PROPERTY(BSDCPIO bsdcpio LOCATION)
-
- # Installation rules
- INSTALL(TARGETS bsdcpio RUNTIME DESTINATION bin)
- INSTALL_MAN(${bsdcpio_MANS})
-
-ENDIF(ENABLE_CPIO)
-
-# Test suite
-add_subdirectory(test)