summaryrefslogtreecommitdiffstats
path: root/Utilities/cmlibarchive/libarchive/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-11-17 20:26:41 (GMT)
committerBrad King <brad.king@kitware.com>2016-11-28 19:55:42 (GMT)
commit7d433206cf7de8f28aa2d169ed25cd401fcfc413 (patch)
tree04c498f437c41bc3ddf92893deef6e59c6baff65 /Utilities/cmlibarchive/libarchive/CMakeLists.txt
parent5cfc2e926af645840c6a0464451af18f08528879 (diff)
downloadCMake-7d433206cf7de8f28aa2d169ed25cd401fcfc413.zip
CMake-7d433206cf7de8f28aa2d169ed25cd401fcfc413.tar.gz
CMake-7d433206cf7de8f28aa2d169ed25cd401fcfc413.tar.bz2
libarchive: Add headers to adapt between OpenSSL 1.1 and older versions
Add private forwarding headers for `openssl/{evp,hmac}.h` to give us a central place to add adaptation code to work across multiple incompatible OpenSSL versions. Provide compatibility implementations of some OpenSSL 1.1 APIs when using older OpenSSL versions.
Diffstat (limited to 'Utilities/cmlibarchive/libarchive/CMakeLists.txt')
-rw-r--r--Utilities/cmlibarchive/libarchive/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Utilities/cmlibarchive/libarchive/CMakeLists.txt b/Utilities/cmlibarchive/libarchive/CMakeLists.txt
index 4eeb5e3..eaa7b20 100644
--- a/Utilities/cmlibarchive/libarchive/CMakeLists.txt
+++ b/Utilities/cmlibarchive/libarchive/CMakeLists.txt
@@ -38,6 +38,8 @@ SET(libarchive_SOURCES
archive_hmac.c
archive_hmac_private.h
archive_match.c
+ archive_openssl_evp_private.h
+ archive_openssl_hmac_private.h
archive_options.c
archive_options_private.h
archive_pack_dev.h