summaryrefslogtreecommitdiffstats
path: root/Utilities/cmliblzma/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-02-26 16:07:46 (GMT)
committerKitware Robot <kwrobot@kitware.com>2019-02-26 16:07:54 (GMT)
commit3c7662fd625079553d3edd004fcf2b3348d38415 (patch)
treef9bbfa6670f0e5fd17f146a5559887b558e9a8b0 /Utilities/cmliblzma/CMakeLists.txt
parent5ac1c809f7cc257807afc1fa779150aa1738fe4a (diff)
parentd9d285c5ad2987ed4aa3ff89093818239781708f (diff)
downloadCMake-3c7662fd625079553d3edd004fcf2b3348d38415.zip
CMake-3c7662fd625079553d3edd004fcf2b3348d38415.tar.gz
CMake-3c7662fd625079553d3edd004fcf2b3348d38415.tar.bz2
Merge topic 'add-xlclang'
d9d285c5ad jsoncpp: Fix include order for build within CMake 0d489fab19 libuv: fix atomic ops compilation with xlclang 1699f5c231 Utilities: Suppress warnings in third-party code when using XLClang f709089d84 XLClang: Extract compiler implicit include directories 5c41386357 XLClang: Add policy CMP0089 to present as XL for compatibility 8278237933 XL: Remove overlap with the new XLClang compiler ID 6f5cf2d2c6 XL: Revert "Recognize compilers identified by __ibmxl__" 90c6156aa8 XLClang: Add a new compiler ID for the clang-based XL compiler ... Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !2921
Diffstat (limited to 'Utilities/cmliblzma/CMakeLists.txt')
-rw-r--r--Utilities/cmliblzma/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Utilities/cmliblzma/CMakeLists.txt b/Utilities/cmliblzma/CMakeLists.txt
index 252f0f9..b443fd6 100644
--- a/Utilities/cmliblzma/CMakeLists.txt
+++ b/Utilities/cmliblzma/CMakeLists.txt
@@ -183,7 +183,7 @@ INCLUDE_DIRECTORIES(
# Disable warnings to avoid changing 3rd party code.
IF(CMAKE_C_COMPILER_ID MATCHES
- "^(GNU|Clang|AppleClang|XL|VisualAge|SunPro|HP|Intel)$")
+ "^(GNU|Clang|AppleClang|XLClang|XL|VisualAge|SunPro|HP|Intel)$")
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -w")
ELSEIF(CMAKE_C_COMPILER_ID STREQUAL "PathScale")
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -woffall")