summaryrefslogtreecommitdiffstats
path: root/Utilities/cmlibrhash/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-11-03 15:23:36 (GMT)
committerBrad King <brad.king@kitware.com>2016-11-10 13:26:55 (GMT)
commitbb01f20e993bbd19b00e07ff0094b155aa0859de (patch)
tree5b899e4e89f3a0480d699d340cb583c7855982e0 /Utilities/cmlibrhash/CMakeLists.txt
parent31bb727f3b239b541e1ff5679b3c461e9a05f227 (diff)
downloadCMake-bb01f20e993bbd19b00e07ff0094b155aa0859de.zip
CMake-bb01f20e993bbd19b00e07ff0094b155aa0859de.tar.gz
CMake-bb01f20e993bbd19b00e07ff0094b155aa0859de.tar.bz2
librhash: Disable warnings to avoid changing 3rd party code
Add '-w' or equivalent flag on compilers supporting it. Tell MSVC to use its lowest warning level inside librhash sources.
Diffstat (limited to 'Utilities/cmlibrhash/CMakeLists.txt')
-rw-r--r--Utilities/cmlibrhash/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Utilities/cmlibrhash/CMakeLists.txt b/Utilities/cmlibrhash/CMakeLists.txt
index 47d069a..968a792 100644
--- a/Utilities/cmlibrhash/CMakeLists.txt
+++ b/Utilities/cmlibrhash/CMakeLists.txt
@@ -1,5 +1,13 @@
project(librhash C)
+# Disable warnings to avoid changing 3rd party code.
+if(CMAKE_C_COMPILER_ID MATCHES
+ "^(GNU|Clang|AppleClang|XL|VisualAge|SunPro|MIPSpro|HP|Intel)$")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -w")
+elseif(CMAKE_C_COMPILER_ID STREQUAL "PathScale")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -woffall")
+endif()
+
set(librhash_sources
librhash/algorithms.c
librhash/algorithms.h