summaryrefslogtreecommitdiffstats
path: root/Utilities/cmlibuv/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-05-16 11:52:11 (GMT)
committerBrad King <brad.king@kitware.com>2017-05-16 11:52:56 (GMT)
commit223d92e0f9c3b9468fff29d3b9b501e57cb201d6 (patch)
tree0d2140982994f46dda9287dd9c7c3fdc808478ed /Utilities/cmlibuv/CMakeLists.txt
parented17516b31404dd42eab61c599c84933af485b34 (diff)
downloadCMake-223d92e0f9c3b9468fff29d3b9b501e57cb201d6.zip
CMake-223d92e0f9c3b9468fff29d3b9b501e57cb201d6.tar.gz
CMake-223d92e0f9c3b9468fff29d3b9b501e57cb201d6.tar.bz2
libuv: Update build within CMake
Update our CMake build rules to account for upstream changes.
Diffstat (limited to 'Utilities/cmlibuv/CMakeLists.txt')
-rw-r--r--Utilities/cmlibuv/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Utilities/cmlibuv/CMakeLists.txt b/Utilities/cmlibuv/CMakeLists.txt
index b6e7941..618f79d 100644
--- a/Utilities/cmlibuv/CMakeLists.txt
+++ b/Utilities/cmlibuv/CMakeLists.txt
@@ -143,6 +143,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
_DARWIN_UNLIMITED_SELECT=1
)
list(APPEND uv_sources
+ src/unix/bsd-ifaddrs.c
src/unix/darwin.c
src/unix/darwin-proctitle.c
src/unix/fsevents.c
@@ -175,8 +176,10 @@ if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
include/uv-bsd.h
)
list(APPEND uv_sources
+ src/unix/bsd-ifaddrs.c
src/unix/freebsd.c
src/unix/kqueue.c
+ src/unix/posix-hrtime.c
)
endif()
@@ -188,8 +191,10 @@ if(CMAKE_SYSTEM_NAME STREQUAL "NetBSD")
include/uv-bsd.h
)
list(APPEND uv_sources
+ src/unix/bsd-ifaddrs.c
src/unix/netbsd.c
src/unix/kqueue.c
+ src/unix/posix-hrtime.c
)
endif()
@@ -201,8 +206,10 @@ if(CMAKE_SYSTEM_NAME STREQUAL "OpenBSD")
include/uv-bsd.h
)
list(APPEND uv_sources
+ src/unix/bsd-ifaddrs.c
src/unix/openbsd.c
src/unix/kqueue.c
+ src/unix/posix-hrtime.c
)
endif()