summaryrefslogtreecommitdiffstats
path: root/Utilities/cmlibuv/CMakeLists.txt
diff options
context:
space:
mode:
authorEarle Lowe <elowe@elowe.com>2019-07-02 22:20:41 (GMT)
committerBrad King <brad.king@kitware.com>2019-09-20 14:30:01 (GMT)
commit5ffb2dbff65bdd5db713ba0c177cecc122cac0d8 (patch)
treecec46a55c8dd1cdb89706f1de4db10f0a2594907 /Utilities/cmlibuv/CMakeLists.txt
parent1059f9a96da377af771fe643abc1d060db6d64bb (diff)
downloadCMake-5ffb2dbff65bdd5db713ba0c177cecc122cac0d8.zip
CMake-5ffb2dbff65bdd5db713ba0c177cecc122cac0d8.tar.gz
CMake-5ffb2dbff65bdd5db713ba0c177cecc122cac0d8.tar.bz2
libuv: Add partial port to HP-UX
Port enough of libuv to HP-UX 11.31 ia64 with GCC 4.9.3 to work for CMake.
Diffstat (limited to 'Utilities/cmlibuv/CMakeLists.txt')
-rw-r--r--Utilities/cmlibuv/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/Utilities/cmlibuv/CMakeLists.txt b/Utilities/cmlibuv/CMakeLists.txt
index 2e781f1..fe2ef75 100644
--- a/Utilities/cmlibuv/CMakeLists.txt
+++ b/Utilities/cmlibuv/CMakeLists.txt
@@ -300,6 +300,23 @@ if(CMAKE_SYSTEM_NAME STREQUAL "SunOS")
)
endif()
+if(CMAKE_SYSTEM_NAME STREQUAL "HP-UX")
+ list(APPEND uv_libraries
+ rt
+ )
+ list(APPEND uv_headers
+ include/uv/posix.h
+ )
+ list(APPEND uv_defines
+ _XOPEN_SOURCE_EXTENDED
+ )
+ list(APPEND uv_sources
+ src/unix/hpux.c
+ src/unix/no-fsevents.c
+ src/unix/posix-poll.c
+ )
+endif()
+
include_directories(
${uv_includes}
${KWSYS_HEADER_ROOT}