summaryrefslogtreecommitdiffstats
path: root/Utilities/cmxmlrpc/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2005-03-16 16:10:42 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2005-03-16 16:10:42 (GMT)
commitb5bf646e4d5bfd7f5be43b04bc59ef905608bad0 (patch)
tree3823f860d22cfa7e1d154d8dacc4b58eb5adbb5a /Utilities/cmxmlrpc/CMakeLists.txt
parent6b43d78dae60a44e9464b8dead6b2347b21e3ab6 (diff)
downloadCMake-b5bf646e4d5bfd7f5be43b04bc59ef905608bad0.zip
CMake-b5bf646e4d5bfd7f5be43b04bc59ef905608bad0.tar.gz
CMake-b5bf646e4d5bfd7f5be43b04bc59ef905608bad0.tar.bz2
BUG: No need to link threads libraries when pthreads are not found
Diffstat (limited to 'Utilities/cmxmlrpc/CMakeLists.txt')
-rw-r--r--Utilities/cmxmlrpc/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Utilities/cmxmlrpc/CMakeLists.txt b/Utilities/cmxmlrpc/CMakeLists.txt
index cef60aa..fd2784a 100644
--- a/Utilities/cmxmlrpc/CMakeLists.txt
+++ b/Utilities/cmxmlrpc/CMakeLists.txt
@@ -97,7 +97,10 @@ IF(WIN32)
ENDIF(WIN32)
ADD_LIBRARY(cmXMLRPC ${xmlrpc_SRCS})
-TARGET_LINK_LIBRARIES(cmXMLRPC ${CMAKE_EXPAT_LIBRARIES} ${CMAKE_CURL_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
+TARGET_LINK_LIBRARIES(cmXMLRPC ${CMAKE_EXPAT_LIBRARIES} ${CMAKE_CURL_LIBRARIES})
+IF(HAVE_PTHREADS)
+ TARGET_LINK_LIBRARIES(cmXMLRPC ${CMAKE_THREAD_LIBS_INIT})
+ENDIF(HAVE_PTHREADS)
ADD_EXECUTABLE(xrtest synch_client.c)
TARGET_LINK_LIBRARIES(xrtest cmXMLRPC)