summaryrefslogtreecommitdiffstats
path: root/Utilities/cmzlib/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-01-14 14:20:27 (GMT)
committerBrad King <brad.king@kitware.com>2015-01-14 14:20:27 (GMT)
commit74b8f7862291d795eba525f3103f1370b8ec7518 (patch)
tree661e286e225071ae97796ccfbb643fce2f7667fb /Utilities/cmzlib/CMakeLists.txt
parent37fd5b87f867351517f469ce02b76bef984dc2c3 (diff)
downloadCMake-74b8f7862291d795eba525f3103f1370b8ec7518.zip
CMake-74b8f7862291d795eba525f3103f1370b8ec7518.tar.gz
CMake-74b8f7862291d795eba525f3103f1370b8ec7518.tar.bz2
zlib: Disable warnings to avoid changing 3rd party code
Diffstat (limited to 'Utilities/cmzlib/CMakeLists.txt')
-rw-r--r--Utilities/cmzlib/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Utilities/cmzlib/CMakeLists.txt b/Utilities/cmzlib/CMakeLists.txt
index 66e8be2..0be48f1 100644
--- a/Utilities/cmzlib/CMakeLists.txt
+++ b/Utilities/cmzlib/CMakeLists.txt
@@ -1,5 +1,13 @@
PROJECT(CMZLIB)
+# Disable warnings to avoid changing 3rd party code.
+if(CMAKE_C_COMPILER_ID MATCHES
+ "^(GNU|Clang|AppleClang|XL|VisualAge|SunPro|MIPSpro|HP|Intel)$")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -w")
+elseif(CMAKE_C_COMPILER_ID STREQUAL "PathScale")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -woffall")
+endif()
+
INCLUDE_DIRECTORIES(
"${CMZLIB_SOURCE_DIR}"
"${CMZLIB_SOURCE_DIR}/.."