summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-08-24 19:45:46 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-08-24 19:45:46 (GMT)
commitd6aee2bc3654890fd6031572bf7dcadeb41c3fe2 (patch)
tree70403961c44d6e15c07e30ccc8f2f02e5a9374bb /configure.in
parent930ea3ef582d5158aabf83ef2f87e21e9401f4bb (diff)
downloadCMake-d6aee2bc3654890fd6031572bf7dcadeb41c3fe2.zip
CMake-d6aee2bc3654890fd6031572bf7dcadeb41c3fe2.tar.gz
CMake-d6aee2bc3654890fd6031572bf7dcadeb41c3fe2.tar.bz2
BUG: fix for SGI Native compiler
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ac1578a..351de58 100644
--- a/configure.in
+++ b/configure.in
@@ -30,7 +30,18 @@ case $system in
echo "$ac_t""no" 1>&6
fi
rm -f conftest*
- ;;
+ ;;
+ IRIX-6* | IRIX64-6* | IRIX-64-6*)
+ echo $ac_n "checking whether ${CC} accepts -LANG:std""... $ac_c" 1>&6
+ echo 'void f(){}' > conftest.c
+ if test -z "`${CC} -LANG:std -c conftest.c 2>&1`"; then
+ echo "$ac_t""yes" 1>&6
+ CMAKE_ANSI_CFLAGS="-LANG:std"
+ else
+ echo "$ac_t""no" 1>&6
+ fi
+ rm -f conftest*
+ ;;
esac
fi
AC_SUBST(CMAKE_ANSI_CFLAGS)