summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-08-24 21:12:58 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-08-24 21:12:58 (GMT)
commitd1ca23a3f9980875dff593da718353c7b9151083 (patch)
tree423a11a1cac17de10111fbe13537fba5452cc8a5 /configure.in
parent03b77686b12b041d4ccb5e3cbc5d7fd12ee32649 (diff)
downloadCMake-d1ca23a3f9980875dff593da718353c7b9151083.zip
CMake-d1ca23a3f9980875dff593da718353c7b9151083.tar.gz
CMake-d1ca23a3f9980875dff593da718353c7b9151083.tar.bz2
auto detect lang:std:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 823a27b..d4030ba 100644
--- a/configure.in
+++ b/configure.in
@@ -102,7 +102,7 @@ if test $ac_cv_prog_gxx = no; then
cat > conftest.cc <<!
#include <iostream>
!
- if test -z "`${CXX} $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
+ if test -z "`${CXX} $CMAKE_TEMPLATE_FLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
echo "$ac_t""yes" 1>&6
else
AC_DEFINE(CMAKE_NO_ANSI_STREAM_HEADERS)
@@ -118,7 +118,7 @@ if test $ac_cv_prog_gxx = no; then
#include <list>
void foo() { std::list<int> l; }
!
- if test -z "`${CXX} $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
+ if test -z "`${CXX} $CMAKE_TEMPLATE_FLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
echo "$ac_t""yes" 1>&6
else
AC_DEFINE(CMAKE_NO_STD_NAMESPACE)
@@ -133,7 +133,7 @@ if test $ac_cv_prog_gxx = no; then
cat > conftest.cc <<!
void foo() { for(int i;;); for(int i;;); }
!
- if test -z "`${CXX} $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
+ if test -z "`${CXX} $CMAKE_TEMPLATE_FLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
echo "$ac_t""yes" 1>&6
else
AC_DEFINE(CMAKE_NO_ANSI_FOR_SCOPE)