summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2003-04-17 12:02:44 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2003-04-17 12:02:44 (GMT)
commit1181ac5ee71f820ac8363b12d262fbff509ce5e2 (patch)
tree9d9d475230ecb83ecd23831b31b12d8ff367f7df /configure.in
parent65422964f793ad1004bf07cbc3021e80e7c241cd (diff)
downloadCMake-1181ac5ee71f820ac8363b12d262fbff509ce5e2.zip
CMake-1181ac5ee71f820ac8363b12d262fbff509ce5e2.tar.gz
CMake-1181ac5ee71f820ac8363b12d262fbff509ce5e2.tar.bz2
BUG: Rename Bootstrap directory to Bootstrap.cmk, so that on platforms such as Windows and Mac OSX it will break during in-source build
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index e5eda4a..fbd0dcc 100644
--- a/configure.in
+++ b/configure.in
@@ -213,23 +213,23 @@ $RUNMAKE
else
PRGNAME=configure # Should be `basename $0`
- DIRNAME=Bootstrap
+ DIRNAME=Bootstrap.cmk
# Check if the bootstrap directory already exists.
- if test -d Bootstrap; then
+ if test -d ${DIRNAME}; then
:
else
# if it does not create one
- mkdir Bootstrap
+ mkdir ${DIRNAME}
fi
if (
# Build bootstrap cmake
- cd Bootstrap
+ cd ${DIRNAME}
echo "Bootstrapping to directory `pwd`"
BUILD_CMAKE_IN_SUBDIR=true $CMAKE_ROOT_DIR/$PRGNAME $ac_configure_args
); then
# run cmake
- Bootstrap/Source/cmake $fullSrcDir
+ ${DIRNAME}/Source/cmake $fullSrcDir
# run cmake depends
$RUNMAKE depend
@@ -237,4 +237,4 @@ else
echo "Problem bootstrapping CMake"
exit 1
fi
-fi \ No newline at end of file
+fi