summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2002-02-14 15:02:09 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2002-02-14 15:02:09 (GMT)
commit2cc36654e65200fbd8c3b702cb449c95d0268a70 (patch)
treecc5e4b7c2177571b0e7138ffed6d317bdad2f9f2 /configure.in
parenta12b5b958bebd3e59520fc7eea565ca661f7f188 (diff)
downloadCMake-2cc36654e65200fbd8c3b702cb449c95d0268a70.zip
CMake-2cc36654e65200fbd8c3b702cb449c95d0268a70.tar.gz
CMake-2cc36654e65200fbd8c3b702cb449c95d0268a70.tar.bz2
ENH: do not use O2 g as default flags
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f99cb21..d25269d 100644
--- a/configure.in
+++ b/configure.in
@@ -9,9 +9,20 @@ AC_SUBST(CMAKE_CONFIG_DIR)
#
# check for some programs we use
#
+
+# save the CFLAGS and CXXFLAGS specified by the user
+save_CFLAGS=$CFLAGS
+save_CXXFLAGS=$CXXFLAGS
+
+# let autoconf find cc and CC, it will try to add -g -O2 to CFLAGS and CXXFLAGS
AC_PROG_CC
AC_PROG_CXX
+# restore the flags specified by the user and get rid of any flags
+# found by autoconf (we do not want -02 -g by default)
+CFLAGS=$save_CFLAGS
+CXXFLAGS=$save_CXXFLAGS
+
fullSrcDir=`cd $srcdir; pwd`
CMAKE_ROOT_DIR=$fullSrcDir
AC_SUBST(CMAKE_ROOT_DIR)