summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-08-08 15:54:46 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-08-08 15:54:46 (GMT)
commitdb1303aa7d00f49a0fdf66f120eb3e6cb0e445fe (patch)
treead569e72f02849e50e625faa1350bb05a3af08f9 /configure.in
parent61ec323b6a1c4e5a44331014447e3d1d31dc1b6b (diff)
downloadCMake-db1303aa7d00f49a0fdf66f120eb3e6cb0e445fe.zip
CMake-db1303aa7d00f49a0fdf66f120eb3e6cb0e445fe.tar.gz
CMake-db1303aa7d00f49a0fdf66f120eb3e6cb0e445fe.tar.bz2
ENH: big change, only allow commands access to the cache via the cmMakefile class and GetDefinition, also the cmMakefile is the only way for commands to add to the cache. Also, some changes to configure.in that check for for scoping
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 11aaae9..ac1578a 100644
--- a/configure.in
+++ b/configure.in
@@ -91,6 +91,21 @@ void foo() { std::list<int> l; }
fi
fi
+# check to see if for scoping is supported
+if test $ac_cv_prog_gxx = no; then
+ AC_MSG_CHECKING( ansi for scope support )
+ rm -rf conftest.*
+ cat > conftest.cc <<!
+void foo() { for(int i;;); for(int i;;); }
+!
+ if test -z "`${CXX} $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
+ echo "$ac_t""yes" 1>&6
+ else
+ AC_DEFINE(CMAKE_NO_ANSI_FOR_SCOPE)
+ echo "$ac_t""no" 1>&6
+ fi
+fi
+
# find make to use to build cmake, prefer gmake
AC_PATH_PROGS(RUNMAKE, gmake make)