summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt57
1 files changed, 39 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6361209..cbb1981 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,7 +6,7 @@ project(expat)
cmake_minimum_required(VERSION 2.6)
set(PACKAGE_BUGREPORT "expat-bugs@libexpat.org")
set(PACKAGE_NAME "expat")
-set(PACKAGE_VERSION "2.1.1")
+set(PACKAGE_VERSION "2.2.1")
set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}")
set(PACKAGE_TARNAME "${PACKAGE_NAME}")
@@ -14,6 +14,8 @@ option(BUILD_tools "build the xmlwf tool for expat library" ON)
option(BUILD_examples "build the examples for expat library" ON)
option(BUILD_tests "build the tests for expat library" ON)
option(BUILD_shared "build a shared expat library" ON)
+option(BUILD_doc "build man page for xmlwf" ON)
+option(INSTALL "install expat files in cmake install target" ON)
# configuration options
set(XML_CONTEXT_BYTES 1024 CACHE STRING "Define to specify how much context to retain around the current parse point")
@@ -37,20 +39,25 @@ endif(BUILD_tests)
include(ConfigureChecks.cmake)
+set(EXTRA_LINK_AND_COMPILE_FLAGS "-fno-strict-aliasing")
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${EXTRA_LINK_AND_COMPILE_FLAGS}")
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${EXTRA_LINK_AND_COMPILE_FLAGS}")
+set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} ${EXTRA_LINK_AND_COMPILE_FLAGS}")
+set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} ${EXTRA_LINK_AND_COMPILE_FLAGS}")
+
include_directories(${CMAKE_BINARY_DIR} ${CMAKE_SOURCE_DIR}/lib)
if(MSVC)
add_definitions(-D_CRT_SECURE_NO_WARNINGS -wd4996)
endif(MSVC)
if(WIN32)
- add_definitions(-DCOMPILING_FOR_WINDOWS)
set(CMAKE_DEBUG_POSTFIX "d" CACHE STRING "Add a suffix, usually d on Windows")
endif(WIN32)
set(expat_SRCS
lib/xmlparse.c
lib/xmlrole.c
- lib/xmltok.c
- lib/xmltok_impl.c
+ lib/xmltok.c
+ lib/xmltok_impl.c
lib/xmltok_ns.c
)
@@ -69,15 +76,23 @@ endif(BUILD_shared)
add_library(expat ${_SHARED} ${expat_SRCS})
set(LIBCURRENT 7) # sync
-set(LIBREVISION 2) # with
+set(LIBREVISION 3) # with
set(LIBAGE 6) # configure.ac!
math(EXPR LIBCURRENT_MINUS_AGE "${LIBCURRENT} - ${LIBAGE}")
-set_property(TARGET expat PROPERTY VERSION ${LIBCURRENT_MINUS_AGE}.${LIBAGE}.${LIBREVISION})
-set_property(TARGET expat PROPERTY SOVERSION ${LIBCURRENT_MINUS_AGE})
-set_property(TARGET expat PROPERTY NO_SONAME ${NO_SONAME})
+if(NOT WIN32)
+ set_property(TARGET expat PROPERTY VERSION ${LIBCURRENT_MINUS_AGE}.${LIBAGE}.${LIBREVISION})
+ set_property(TARGET expat PROPERTY SOVERSION ${LIBCURRENT_MINUS_AGE})
+ set_property(TARGET expat PROPERTY NO_SONAME ${NO_SONAME})
+endif(NOT WIN32)
+
+macro(expat_install)
+ if(INSTALL)
+ install(${ARGN})
+ endif()
+endmacro()
-install(TARGETS expat RUNTIME DESTINATION bin
+expat_install(TARGETS expat RUNTIME DESTINATION bin
LIBRARY DESTINATION lib
ARCHIVE DESTINATION lib)
@@ -87,11 +102,8 @@ set(libdir "\${prefix}/lib")
set(includedir "\${prefix}/include")
configure_file(expat.pc.in ${CMAKE_CURRENT_BINARY_DIR}/expat.pc)
-install(FILES lib/expat.h lib/expat_external.h DESTINATION include)
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/expat.pc DESTINATION lib/pkgconfig)
-
-
-add_custom_command(TARGET expat PRE_BUILD COMMAND $(MAKE) -C doc xmlwf.1)
+expat_install(FILES lib/expat.h lib/expat_external.h DESTINATION include)
+expat_install(FILES ${CMAKE_CURRENT_BINARY_DIR}/expat.pc DESTINATION lib/pkgconfig)
if(BUILD_tools AND NOT WINCE)
set(xmlwf_SRCS
@@ -104,8 +116,17 @@ if(BUILD_tools AND NOT WINCE)
add_executable(xmlwf ${xmlwf_SRCS})
set_property(TARGET xmlwf PROPERTY RUNTIME_OUTPUT_DIRECTORY xmlwf)
target_link_libraries(xmlwf expat)
- install(TARGETS xmlwf DESTINATION bin)
- install(FILES doc/xmlwf.1 DESTINATION share/man/man1)
+ expat_install(TARGETS xmlwf DESTINATION bin)
+ if(BUILD_doc AND NOT MSVC)
+ if(CMAKE_GENERATOR STREQUAL "Unix Makefiles")
+ set(make_command "$(MAKE)")
+ else()
+ set(make_command "make")
+ endif()
+
+ add_custom_command(TARGET expat PRE_BUILD COMMAND "${make_command}" -C "${PROJECT_SOURCE_DIR}/doc" xmlwf.1)
+ expat_install(FILES "${PROJECT_SOURCE_DIR}/doc/xmlwf.1" DESTINATION share/man/man1)
+ endif()
endif(BUILD_tools AND NOT WINCE)
if(BUILD_examples)
@@ -120,12 +141,12 @@ endif(BUILD_examples)
if(BUILD_tests)
## these are unittests that can be run on any platform
- add_executable(runtests tests/runtests.c tests/chardata.c tests/minicheck.c)
+ add_executable(runtests tests/runtests.c tests/chardata.c tests/minicheck.c tests/memcheck.c)
set_property(TARGET runtests PROPERTY RUNTIME_OUTPUT_DIRECTORY tests)
target_link_libraries(runtests expat)
add_test(runtests tests/runtests)
- add_executable(runtestspp tests/runtestspp.cpp tests/chardata.c tests/minicheck.c)
+ add_executable(runtestspp tests/runtestspp.cpp tests/chardata.c tests/minicheck.c tests/memcheck.c)
set_property(TARGET runtestspp PROPERTY RUNTIME_OUTPUT_DIRECTORY tests)
target_link_libraries(runtestspp expat)
add_test(runtestspp tests/runtestspp)