summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54fb7f1..013711a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,6 +60,13 @@ SUBDIRS(Source/kwsys)
SET(CMAKE_BUILD_WITH_CURL 1)
SUBDIRS(Source/CTest/Curl)
+IF (UNIX)
+ INCLUDE (${CMake_SOURCE_DIR}/Modules/FindCurses.cmake OPTIONAL)
+ IF (CURSES_LIBRARY)
+ SUBDIRS(Source/CursesDialog/form)
+ ENDIF (CURSES_LIBRARY)
+ENDIF (UNIX)
+
SUBDIRS(Source Modules Templates Utilities)
ENABLE_TESTING()