summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 12 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee10117..59bcc30 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -319,14 +319,19 @@ MACRO (CMAKE_BUILD_UTILITIES)
#---------------------------------------------------------------------
# Use curses?
IF (UNIX)
- SET(CURSES_NEED_NCURSES TRUE)
- FIND_PACKAGE(Curses QUIET)
- IF (CURSES_LIBRARY)
- OPTION(BUILD_CursesDialog "Build the CMake Curses Dialog ccmake" ON)
- ELSE (CURSES_LIBRARY)
- MESSAGE("Curses libraries were not found. Curses GUI for CMake will not be built.")
+ # there is a bug in the Syllable libraries which makes linking ccmake fail, Alex
+ IF(NOT "${CMAKE_SYSTEM_NAME}" MATCHES syllable)
+ SET(CURSES_NEED_NCURSES TRUE)
+ FIND_PACKAGE(Curses QUIET)
+ IF (CURSES_LIBRARY)
+ OPTION(BUILD_CursesDialog "Build the CMake Curses Dialog ccmake" ON)
+ ELSE (CURSES_LIBRARY)
+ MESSAGE("Curses libraries were not found. Curses GUI for CMake will not be built.")
+ SET(BUILD_CursesDialog 0)
+ ENDIF (CURSES_LIBRARY)
+ ELSE(NOT "${CMAKE_SYSTEM_NAME}" MATCHES syllable)
SET(BUILD_CursesDialog 0)
- ENDIF (CURSES_LIBRARY)
+ ENDIF(NOT "${CMAKE_SYSTEM_NAME}" MATCHES syllable)
ELSE (UNIX)
SET(BUILD_CursesDialog 0)
ENDIF (UNIX)