summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41ff4a6..e210f74 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -201,12 +201,6 @@ endmacro()
#-----------------------------------------------------------------------
macro (CMAKE_BUILD_UTILITIES)
#---------------------------------------------------------------------
- # Create the KWIML library for CMake.
- set(KWIML cmIML)
- set(KWIML_HEADER_ROOT ${CMake_BINARY_DIR}/Utilities)
- add_subdirectory(Utilities/KWIML)
-
- #---------------------------------------------------------------------
# Create the kwsys library for CMake.
set(KWSYS_NAMESPACE cmsys)
set(KWSYS_USE_SystemTools 1)
@@ -465,6 +459,11 @@ if("x${CMAKE_TESTS_CDASH_SERVER}" STREQUAL "x")
set(CMAKE_TESTS_CDASH_SERVER "http://open.cdash.org")
endif()
+# Create the KWIML library for CMake.
+set(KWIML cmIML)
+set(KWIML_HEADER_ROOT ${CMake_BINARY_DIR}/Utilities)
+add_subdirectory(Utilities/KWIML)
+
if(NOT CMake_TEST_EXTERNAL_CMAKE)
# build the utilities (a macro defined in this file)
CMAKE_BUILD_UTILITIES()