summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3aef619..958beb6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -464,6 +464,19 @@ macro (CMAKE_BUILD_UTILITIES)
endif()
#---------------------------------------------------------------------
+ # Build libuv library.
+ if(NOT DEFINED CMAKE_USE_LIBUV)
+ set(CMAKE_USE_LIBUV 1)
+ endif()
+ if(CMAKE_USE_LIBUV)
+ set(CMAKE_LIBUV_LIBRARIES cmlibuv)
+ add_subdirectory(Utilities/cmlibuv)
+ CMAKE_SET_TARGET_FOLDER(cmlibuv "Utilities/3rdParty")
+ else()
+ set(CMAKE_LIBUV_LIBRARIES)
+ endif()
+
+ #---------------------------------------------------------------------
# Build XMLRPC library for CMake and CTest.
if(CTEST_USE_XMLRPC)
find_package(XMLRPC QUIET REQUIRED libwww-client)