summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ce3af2..6a26858 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -695,13 +695,13 @@ endif()
CMAKE_SETUP_TESTING()
# Check whether to build server mode or not:
-set(CMake_HAVE_SERVER_MODE 0)
+set(CMake_ENABLE_SERVER_MODE 0)
if(NOT CMake_TEST_EXTERNAL_CMAKE AND CMAKE_USE_LIBUV)
list(FIND CMAKE_CXX_COMPILE_FEATURES cxx_auto_type CMake_HAVE_CXX_AUTO_TYPE)
list(FIND CMAKE_CXX_COMPILE_FEATURES cxx_range_for CMake_HAVE_CXX_RANGE_FOR)
if(CMake_HAVE_CXX_AUTO_TYPE AND CMake_HAVE_CXX_RANGE_FOR)
if(CMake_HAVE_CXX_MAKE_UNIQUE)
- set(CMake_HAVE_SERVER_MODE 1)
+ set(CMake_ENABLE_SERVER_MODE 1)
endif()
endif()
endif()