summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 134f3d7..510aa0f 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -730,6 +730,10 @@ IF(BUILD_TESTING)
IF("${CMAKE_GENERATOR}" MATCHES XCode)
SET(CMAKE_SKIP_BOOTSTRAP_TEST 1)
ENDIF("${CMAKE_GENERATOR}" MATCHES XCode)
+ IF(EXISTS "${CMAKE_BINARY_DIR}/CMakeLists.txt")
+ # If there is CMakeLists.txt in the binary tree, assume in-source build
+ SET(CMAKE_SKIP_BOOTSTRAP_TEST 1)
+ ENDIF(EXISTS "${CMAKE_BINARY_DIR}/CMakeLists.txt")
IF(UNIX AND CMAKE_RUN_LONG_TESTS AND NOT CMAKE_SKIP_BOOTSTRAP_TEST)
ADD_TEST(BootstrapTest ${CMAKE_CTEST_COMMAND}
--build-and-test