summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index f51f358..80c1fe8 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -1,5 +1,4 @@
INCLUDE (${CMAKE_ROOT}/Modules/FindFLTK.cmake)
-
IF(FLTK_LIBRARY)
IF(FLTK_INCLUDE_PATH)
OPTION(BUILD_FLTK_GUI "Build FLTK CMake GUI." "ON")
@@ -47,6 +46,13 @@ IF (WIN32)
ENDIF(NOT UNIX)
ENDIF (WIN32)
+IF (UNIX)
+ INCLUDE (${CMAKE_ROOT}/Modules/FindCurses.cmake)
+ IF (CURSES_LIBRARY AND FORM_LIBRARY)
+ SUBDIRS(CursesDialog)
+ ENDIF (CURSES_LIBRARY AND FORM_LIBRARY)
+IF (UNIX)
+
SOURCE_FILES(SRCS cmUnixMakefileGenerator.cxx)