summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 574e69d..915097e 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -173,10 +173,13 @@ SET(SRCS
# Kdevelop only works on UNIX and not windows
IF(UNIX)
- SET(SRCS ${SRCS}
- cmGlobalKdevelopGenerator.cxx
- cmExtraCodeBlocksGenerator.cxx)
+ SET(SRCS ${SRCS} cmGlobalKdevelopGenerator.cxx)
ENDIF(UNIX)
+
+IF(NOT CYGWIN)
+ SET(SRCS ${SRCS} cmExtraCodeBlocksGenerator.cxx)
+ENDIF(NOT CYGWIN)
+
# XCode only works on apple
IF(APPLE)
SET(SRCS ${SRCS}