summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index bd27b33..efe2b9f 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -406,7 +406,11 @@ IF(BUILD_TESTING)
IF(CMAKE_CONFIGURATION_TYPES)
SET(LIBNAME_DIR Debug)
ENDIF(CMAKE_CONFIGURATION_TYPES)
-
+ IF(WIN32)
+ SET(RUN_DIR "${CMake_BINARY_DIR}/Tests/LibName/lib/${LIBNAME_DIR}")
+ ELSE(WIN32)
+ SET(RUN_DIR "${CMake_BINARY_DIR}/Tests/LibName/")
+ ENDIF(WIN32)
ADD_TEST(LibName ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/LibName"
@@ -415,7 +419,7 @@ IF(BUILD_TESTING)
--build-generator ${CMAKE_TEST_GENERATOR}
--build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
--build-project LibName
- --build-run-dir "${CMake_BINARY_DIR}/Tests/LibName/lib/${LIBNAME_DIR}"
+ --build-run-dir "${RUN_DIR}"
--test-command foobar
)