summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 3ba2ff1..13b2416 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -228,6 +228,16 @@ IF(BUILD_TESTING)
--build-two-config
--test-command simple)
+ ADD_TEST(PreOrder ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/PreOrder"
+ "${CMake_BINARY_DIR}/Tests/PreOrder"
+ --build-generator ${CMAKE_GENERATOR}
+ --build-project PreOrder
+ --build-makeprogram ${MAKEPROGRAM}
+ --build-two-config
+ --test-command simple)
+
ADD_TEST(conly ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/COnly"