summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 817ee9f..37ab5b3 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -56,8 +56,6 @@ SET(SRCS
cmListFileLexer.c
cmLocalGenerator.cxx
cmLocalGenerator.h
- cmLocalUnixMakefileGenerator.cxx
- cmLocalUnixMakefileGenerator.h
cmLocalUnixMakefileGenerator2.cxx
cmLocalXCodeGenerator.cxx
cmMakeDepend.cxx
@@ -292,6 +290,17 @@ IF(BUILD_TESTING)
--build-two-config
--test-command simple)
+ ADD_TEST(OutOfSource ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/OutOfSource"
+ "${CMake_BINARY_DIR}/Tests/OutOfSource"
+ --build-generator ${CMAKE_GENERATOR}
+ --build-project OutOfSource
+ --build-makeprogram ${MAKEPROGRAM}
+ --build-two-config
+ --test-command
+ "${CMake_BINARY_DIR}/Tests/OutOfSource/SubDir/OutOfSourceSubdir/simple")
+
ADD_TEST(PreOrder ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/PreOrder"