summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index fef89de..5d9b109 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -42,6 +42,7 @@ cmLocalUnixMakefileGenerator.h
cmVariableWatch.h
)
+
# configure the .h file
CONFIGURE_FILE(
${CMake_SOURCE_DIR}/Source/cmConfigure.cmake.h.in
@@ -63,6 +64,14 @@ IF (APPLE)
)
ENDIF (APPLE)
+# Kdevelop only works on UNIX and not windows
+IF(UNIX AND NOT WIN32)
+ SET(SRCS ${SRCS}
+ cmGlobalKdevelopGenerator.cxx
+ cmLocalKdevelopGenerator.cxx)
+ENDIF(UNIX AND NOT WIN32)
+
+
IF (WIN32)
IF(NOT UNIX)
SET(SRCS ${SRCS}