summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index be55bb2..7f16987 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -986,6 +986,8 @@ IF(BUILD_TESTING)
--test-command executable
)
+ # Disable this test by default until it works everywhere.
+ IF(CMAKE_TEST_ENABLE_Plugin)
ADD_TEST(Plugin ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/Plugin"
@@ -995,6 +997,7 @@ IF(BUILD_TESTING)
--build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
--build-two-config
--test-command bin/example)
+ ENDIF(CMAKE_TEST_ENABLE_Plugin)
IF(NOT CMAKE_TEST_DIFFERENT_GENERATOR)
ADD_TEST(kwsys ${CMAKE_CTEST_COMMAND}