summaryrefslogtreecommitdiffstats
path: root/Source/CTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/CTest/CMakeLists.txt')
-rw-r--r--Source/CTest/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/Source/CTest/CMakeLists.txt b/Source/CTest/CMakeLists.txt
new file mode 100644
index 0000000..130caea
--- /dev/null
+++ b/Source/CTest/CMakeLists.txt
@@ -0,0 +1,18 @@
+CMAKE_MINIMUM_REQUIRED(VERSION 1.5)
+PROJECT(CTEST CXX)
+
+SUBDIRS(Curl)
+
+FIND_LIBRARY(CMAKE_LIBRARY NAMES CMakeLib PATHS
+ ${CTEST_BINARY_DIR}/..)
+
+SET(CTEST_SRCS
+ ../ctest.cxx
+ ../cmCTest.cxx
+ cmCTestSubmit.cxx)
+
+INCLUDE_DIRECTORIES(${CTEST_SOURCE_DIR}/..)
+
+ADD_DEFINITIONS(-DHAVE_CURL)
+ADD_EXECUTABLE(ctest ${CTEST_SRCS})
+TARGET_LINK_LIBRARIES(ctest ${CMAKE_LIBRARY} Curl) \ No newline at end of file