summaryrefslogtreecommitdiffstats
path: root/Source/CTest/Curl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/CTest/Curl/CMakeLists.txt')
-rw-r--r--Source/CTest/Curl/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/Source/CTest/Curl/CMakeLists.txt b/Source/CTest/Curl/CMakeLists.txt
index ef3911a..9190345 100644
--- a/Source/CTest/Curl/CMakeLists.txt
+++ b/Source/CTest/Curl/CMakeLists.txt
@@ -95,7 +95,10 @@ MACRO(CHECK_LIBRARY_EXISTS_CONCAT LIBRARY SYMBOL VARIABLE)
ENDMACRO(CHECK_LIBRARY_EXISTS_CONCAT)
# Check for all needed libraries
-CHECK_LIBRARY_EXISTS_CONCAT("dl" dlopen HAVE_LIBDL)
+
+# We do not need this because we do not use ldap.
+# CHECK_LIBRARY_EXISTS_CONCAT("dl" dlopen HAVE_LIBDL)
+
CHECK_LIBRARY_EXISTS_CONCAT("ucb" gethostname HAVE_LIBUCB)
CHECK_LIBRARY_EXISTS_CONCAT("socket" connect HAVE_LIBSOCKET)
CHECK_LIBRARY_EXISTS("c" gethostbyname "" NOT_NEED_LIBNSL)
@@ -114,7 +117,8 @@ IF(CMAKE_USE_OPENSSL)
ENDIF(CMAKE_USE_OPENSSL)
# Check for symbol dlopen (same as HAVE_LIBDL)
-CHECK_LIBRARY_EXISTS("${CURL_LIBS}" dlopen "" HAVE_DLOPEN)
+# We do not need this because we do not use ldap.
+# CHECK_LIBRARY_EXISTS("${CURL_LIBS}" dlopen "" HAVE_DLOPEN)
# For other tests to use the same libraries
SET(CMAKE_REQUIRED_LIBRARIES ${CURL_LIBS})