summaryrefslogtreecommitdiffstats
path: root/Source/MFCDialog/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/MFCDialog/CMakeLists.txt')
-rw-r--r--Source/MFCDialog/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/Source/MFCDialog/CMakeLists.txt b/Source/MFCDialog/CMakeLists.txt
new file mode 100644
index 0000000..e0a9938
--- /dev/null
+++ b/Source/MFCDialog/CMakeLists.txt
@@ -0,0 +1,16 @@
+SOURCE_FILES(SRCS
+CMakeSetup.cpp
+CMakeSetup.rc
+CMakeSetupDialog.cpp
+PathDialog.cpp
+PropertyList.cpp
+StdAfx.cpp
+res/CMakeSetupDialog.ico
+res/CMakeSetupDialog.rc2
+)
+
+# add stuff to use MFC in this executable
+ADD_DEFINITIONS(-D_AFXDLL)
+SET(CMAKE_MFC_FLAG 6)
+
+ADD_EXECUTABLE(CMakeSetup WIN32 SRCS)