summaryrefslogtreecommitdiffstats
path: root/Source/MFCDialog/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/MFCDialog/CMakeLists.txt')
-rw-r--r--Source/MFCDialog/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/Source/MFCDialog/CMakeLists.txt b/Source/MFCDialog/CMakeLists.txt
index c23a3bb..35609f3 100644
--- a/Source/MFCDialog/CMakeLists.txt
+++ b/Source/MFCDialog/CMakeLists.txt
@@ -11,7 +11,13 @@ SET( SRCS
# add stuff to use MFC in this executable
ADD_DEFINITIONS(-D_AFXDLL)
-SET(CMAKE_MFC_FLAG 6)
+
+# Use of CMAKE_MFC_FLAG
+# Values:
+# 0: Use Standard Windows Libraries
+# 1: Use MFC in a Static Library
+# 2: Use MFC in a Shared DLL
+SET(CMAKE_MFC_FLAG 2)
ADD_EXECUTABLE(CMakeSetup WIN32 ${SRCS})
TARGET_LINK_LIBRARIES(CMakeSetup CMakeLib)