summaryrefslogtreecommitdiffstats
path: root/Source/QtDialog/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/QtDialog/CMakeLists.txt')
-rw-r--r--Source/QtDialog/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/Source/QtDialog/CMakeLists.txt b/Source/QtDialog/CMakeLists.txt
index dc77a28..2e61c29 100644
--- a/Source/QtDialog/CMakeLists.txt
+++ b/Source/QtDialog/CMakeLists.txt
@@ -66,6 +66,15 @@ ELSE(NOT QT4_FOUND)
INSTALL(TARGETS cmake-gui RUNTIME DESTINATION bin
${CMAKE_INSTALL_DESTINATION_ARGS})
ENDIF(CMAKE_PACKAGE_QTGUI)
+
+ IF(UNIX)
+ # install a desktop file so CMake appears in the application start menu
+ # with an icon
+ INSTALL(FILES CMake.desktop DESTINATION share/applications )
+ INSTALL(FILES CMakeSetup.png DESTINATION share/pixmaps )
+ INSTALL(FILES cmakecache.xml DESTINATION share/mime/packages )
+ ENDIF(UNIX)
+
IF(APPLE)
SET(CMAKE_POSTFLIGHT_SCRIPT
"${CMake_BINARY_DIR}/Source/QtDialog/postflight.sh")