summaryrefslogtreecommitdiffstats
path: root/Templates/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'Templates/configure.in')
-rw-r--r--Templates/configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/Templates/configure.in b/Templates/configure.in
index ab6bd3e..d738f47 100644
--- a/Templates/configure.in
+++ b/Templates/configure.in
@@ -536,6 +536,23 @@ fi
AC_SUBST(CMAKE_NO_ANSI_STREAM_HEADERS)
+# check to see if for scoping is supported
+if test $ac_cv_prog_gxx = no; then
+ AC_MSG_CHECKING( ansi for scope support )
+ rm -rf conftest.*
+ cat > conftest.cc <<!
+void foo() { for(int i;;); for(int i;;); }
+!
+ if test -z "`${CXX} $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
+ echo "$ac_t""yes" 1>&6
+ else
+ CMAKE_NO_ANSI_FOR_SCOPE="1"
+ echo "$ac_t""no" 1>&6
+ fi
+fi
+AC_SUBST(CMAKE_NO_ANSI_FOR_SCOPE)
+
+
if test "$CC" = "gcc" -o `$CC -v 2>&1 | grep -c gcc` != "0" ; then
SHLIB_CFLAGS="-fPIC"
fi