summaryrefslogtreecommitdiffstats
path: root/Templates/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'Templates/configure.in')
-rw-r--r--Templates/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/Templates/configure.in b/Templates/configure.in
index 7955b2c..c74091b 100644
--- a/Templates/configure.in
+++ b/Templates/configure.in
@@ -429,6 +429,14 @@ case $system in
;;
esac
+# if running on darwin no explicit template instantiations
+case $system in
+ Darwin*)
+ CMAKE_NO_EXPLICIT_TEMPLATE_INSTANTIATION="1"
+ ;;
+esac
+AC_SUBST(CMAKE_NO_EXPLICIT_TEMPLATE_INSTANTIATION)
+
# If the user has supplied C flags for compiling shared objects, use
# those instead
if test "${SHLIB_CFLAGS}" != ""; then