summaryrefslogtreecommitdiffstats
path: root/Templates/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'Templates/configure.in')
-rw-r--r--Templates/configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/Templates/configure.in b/Templates/configure.in
index 4497538..d576ba3 100644
--- a/Templates/configure.in
+++ b/Templates/configure.in
@@ -567,7 +567,15 @@ case $system in
rm -f conftest*
;;
IRIX-5* | IRIX-6* | IRIX64-6* | IRIX-64-6*)
- CMAKE_ANSI_CXXFLAGS="-LANG:std"
+ echo $ac_n "checking whether ${CXX} accepts -LANG:std""... $ac_c" 1>&6
+ echo 'void f(){}' > conftest.c
+ if test -z "`${CXX} -LANG:std -c conftest.c 2>&1`"; then
+ echo "$ac_t""yes" 1>&6
+ CMAKE_ANSI_CXXFLAGS="-LANG:std"
+ else
+ echo "$ac_t""no" 1>&6
+ fi
+ rm -f conftest*
;;
esac
fi