summaryrefslogtreecommitdiffstats
path: root/Templates/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'Templates/configure.in')
-rw-r--r--Templates/configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/Templates/configure.in b/Templates/configure.in
index 62f2a51..c74091b 100644
--- a/Templates/configure.in
+++ b/Templates/configure.in
@@ -582,6 +582,22 @@ fi
AC_SUBST(CMAKE_ANSI_CFLAGS)
AC_SUBST(CMAKE_ANSI_CXXFLAGS)
+# if we are not running g++ then we might need some other flags
+# to get the templates compiled correctly
+CMAKE_TEMPLATE_FLAGS=""
+if test $ac_cv_prog_gxx = no; then
+ echo $ac_n "checking whether ${CXX} accepts -ptused -no_prelink""... $ac_c" 1>&6
+ echo 'void f(){}' > conftest.cc
+ if test -z "`${CXX} -ptused -no_prelink -c conftest.cc 2>&1`"; then
+ echo "$ac_t""yes" 1>&6
+ CMAKE_TEMPLATE_FLAGS="-ptused -no_prelink"
+ else
+ echo "$ac_t""no" 1>&6
+ fi
+ rm -f conftest*
+fi
+AC_SUBST(CMAKE_TEMPLATE_FLAGS)
+
# check no g++ compilers to see if they have the standard
# ansi stream files (without the .h)